Macromedia Contribute 3 Fundamentals

Welcome to Contribute

Macromedia Contribute enables users to easily create and edit web pages on existing websites.  Whether you’re the one using Contribute to edit web pages or the one managing the website, you’ll find Contribute a very useful tool for browsing, editing, and publishing content to a website.

Overview

Macromedia Contribute makes it easier for authorized individuals to rapidly publish and change content on your Web site, even if these individuals are non-technical.  Contribute facilitates content conversion from Microsoft Word or Excel, enforces site design standards, enables you to roll back undesirable site changes, and allows you to grant specific individuals access to change only certain areas of your Web site.
Roles

Contribute website administrators set up Contribute users, train them and provide technical assistance to them in using Contribute to maintain the website.  The administrator is also responsible for determining which users can edit what content on the website, by setting various user profiles and permissions.  There can be only one website administrator named for each website in Contribute.  However, more than one person can administer the website if the website administrator shares the administration password for the website.  It’s always helpful to have a backup person.

Publishers can create new Web pages, edit existing Web pages, review new and edited Web pages, forward (or return) drafts to others for review or additional work and “Publish” Web pages (post to the website).  

Editors/ Authors can create new Web pages, edit existing Web pages, forward drafts to others for review Editors can not “Publish” Web pages (can not post to the website).  

Administrators can set up multiple definitions (permission settings) for publishers and editors.  i.e.,  Some publishers and editors can have different profiles.
Contribute, Dreamweaver and Both 
Contribute is designed to be used as a website content management tool by persons providing new or maintaining the existing content of Web pages on established website to keep the websites content up-to-date.  Contribute users do not have to be web technicians.  
Dreamweaver is designed to be a website development tool used by Web developers (or design team) to create and maintain websites, Templates and Web based applications.  Dreamweaver users are usually skilled web technicians, or people with more technical knowledge or skills about Web development practices. 
What if I use both, Contribute and Dreamweaver?

It is not unusual for someone to be responsible for maintaining content on one or more websites using Contribute and also be the developer of the same or another Web(s) site using Dreamweaver. Therefore, sometime both products are installed on the same computer.  
In this case, upon initiating some tasks, Dreamweaver detects the presence of Contribute and will ask “This site has been set up for use by Macromedia Contribute users.  Do you want Dreamweaver enable all required site settings for compatibility with Contribute sites?”  If you answer “No”, you can use either product without them interfering with each other.  If you answer “Yes”, Dreamweaver will activate (among other things) the “Check in Check out” features which may cause files opened in a Dreamweaver defined site to be unavailable to either Contribute or Dreamweaver users of the same site unless they are either manually checked back in or the “Check Out (files)” and the “Check In” method of transferring files (preferred) is used.
If Contribute users report that files are not available to them (Checked-out by someone else), whoever has the files checked out will have to check them back in before they can be used by someone else.  This, is at the least a nuisance, and can be a serious problem if the person that has the file(s) checked out is not available at the time someone else needs access to them.
Each office and its Contribute administrator will need to establish a policy on how these two products are to be used when installed on the same computer.
Objectives

During the workshop we will learn how to: 
· Establish a connection to a website, create and edit Web pages using Contribute.
· Practice using Contribute on a Web site in the classroom.
· Discuss recommended guidelines and naming conventions.

· Discuss some of the factors that may interfere with publishing Web pages managed through Contribute (Troubleshooting issues).
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Introduction to Contribute 

Installing and Starting Contribute

If Contribute is not already installed on your computer or available from your applications launcher, ask your Contribute Administrator to install it for you or to provide you the Contribute CD so you can install it yourself.  If installing it on a PC, se the self install feature included on the CD or use the Control Panel’s “Add Remove Programs” feature.  
After Contribute is installed on your computer, you can start the program by:

· double-click the Contribute icon on your desktop, 
· double click on the Contribute icon in the Application Launcher, or 
· by choosing:
Start > Programs > Macromedia > Macromedia Contribute
 to launch Contribute.
Understanding the Contribute work space (interface)

The Contribute workspace is made up of the following main areas: 

· Contribute browser/editor
In the Contribute browser, you can browse to any web page—not just pages on your website.  The Contribute browser functions as a true web browser; simply click links in web pages to browse to the page you want to edit.  You can also create bookmarks to pages that you visit frequently.  In the Contribute editor, you can edit pages in websites you’ve connected to.  You can edit text, images, tables, links, and even pages with frames.  Then, you can publish your changes to make the updated web page live on your website.  It’s easy to browse and edit in Contribute, and to switch between browsing and editing.

· toolbar, 
The Contribute toolbar changes, depending on whether you are browsing or editing a page.  
· The browser toolbar contains buttons for navigating your website or creating a new page.  
· The editor toolbar contains buttons for editing and common operations from the File, Insert, Format, and Table menus.
· sidebar.
The Contribute sidebar makes it easy to switch between editing and browsing, and makes it easy to access your drafts and newly created pages.  You can also use the sidebar to get quick instructions for performing tasks in Contribute.

· The sidebar has two parts:
· The Pages panel includes access to the web browser and all drafts and new pages you’re currently editing.  Drafts you are currently editing, and new pages you’ve created but haven’t published yet, appear in the Pages panel.  You can also access these pages using the File menu. 

· The How Do I panel provides quick step-by-step instructions to help you complete some common Contribute tasks.  The list of tasks changes, depending on whether you’re browsing or editing.  Click any link in the How Do I panel in the sidebar to get more information on that task.  If the task you’re looking for is not in the list, see Contribute Help (Help > Macromedia Contribute Help to get detailed information.
You can expand or collapse the panels and the sidebar.

To expand or collapse the sidebar:

· Select View > Sidebar or click the arrow on the splitter bar between the sidebar and the Contribute browser/editor.

To resize the sidebar:

· Drag the splitter bar between the sidebar and the Contribute browser/editor.

Getting Started

Contribute users should start with the Quick Start guide to understand how to use Contribute to complete basic tasks.  Then, complete the tutorial to update some sample web pages and learn more about Contribute.  As you use Contribute, refer to the How Do I panel for quick steps to complete common tasks, and refer to the online help to get more detailed and complete information about Contribute tasks and features.

Getting help

The following Help for learning Contribute is readily available from within the program:

· A video introductory tutorial - Click on Help > Quickstart Guide 

· “Contribute How Do I”, panel in the left sidebar.  It provides quick step-by-step instructions to help you complete some common tasks.  Click on the black arrowhead to expand or collapse the panel.

· A more complete “Contribute Tutorial” is available by clicking on Help > Contribute Tutorial.  The Table of contents will then appear in the Contribute How Do I”, panel.

· The complete (214 pages, PDF) manual “Using Contribute” is included in the “contribute_resources” folder in the class materials. 
· Press F1 or select Help > Macromedia Contribute Help or click the Help button in any dialog box.
· Adobe/Macromedia support center is available at:
http://www.macromedia.com/support/contribute/ 

· Your Contribute Administrator.

· Your departmental Help Desk.  Look at:
http://help.ncsu.edu/otherhelp.php 

· The NC State Help Desk:
http://help.ncsu.edu/ 

Understanding Contribute's workflow

Contribute uses a browse-edit-publish workflow to help you easily find the page you want to edit, make changes to the page, and then update the page on your website.

Note: You must connect to a website before you can edit and publish pages on that website.
Q. What does “browse-edit-publish” mean?
A. It means that, once you are connected to a web site, you will use Contribute (just like a Web Browser) to find the Web page you want to edit.  Then you will select “Edit Page”.  This activated Contribute’s editing features.  Then you can edit the page (within the capabilities established by the administrator).  After you have finished editing the page, you can then “Send for Review”, or you can “Publish” it to the Website (if you have been granted “Publisher” privileges).  This is Contribute’s workflow.

Understanding the draft review process 

There are a couple of options to this workflow.  The first is that you may have publishing privileges and are authorized to “Publish” (post to the website) the page yourself. i.e.,  You do not have to send it to anyone else for review.  However, you will still have the option to “Send for Review” if you want someone else to review it before it is published.

Sending your Page through a Review Cycle

Other options include - You may receive a request to review a document but upon inspecting it, you would like for additional changes to be made.  In this situation, you may either; apply the changes yourself then publish the page or, you may send it to someone else for review with a request for them to make the changes.  Or, if you can “Send for Review” back to the person that sent it to you with a note for them to make further changes/corrections.  In any of these situations, you should make it clear who else needs to be involved in the review process and who (finally) gets to publish it.  The bureaucracy never ends.

Understanding the email review process

When using this workflow, it is strongly that you always use the “Notify recipients through email” feature so that the reviewer will receive an email notifying them that there documents waiting for them to review and publish.  Otherwise, they will not know anything is waiting for them until they open Contribute and look in their “Draft Console”.

Editable pages and non-editable pages

When you are browsing through Web pages, you will be visiting both pages that you are authorized to edit and ones that you are not authorized to edit.  How can you tell the difference?  When viewing a page in Contribute’s browser.  If you see a yellow bar just under the “Address:” bar, then you have arrived at a page that you are not authorized to edit.  This yellow warning bar will contain a Caution icon, a message and the name of an administrator that may be able to assist you if you need to work with that page.

Note:  Occasionally, you may get some type of “Not Authorized” or “Access Denied” message.  If this occurs, contact the Contribute administrator to have them adjust your “permissions”.
Connecting to a Website with Contribute 

Using a connection key

Contribute enables you to connect to your website quickly and easily.  Your Contribute website administrator will likely do one of the following to help set up a connection for you:

Send you an email with either:

· A website connection key attached.  The connection key contains all of the network information Contribute needs to connect to your website.  
Note: Your website administrator should also communicate the connection key password to you.  If you do not know the password, contact your website administrator.
· A link or network location for you to download the connection key.  Or,

· Provide you with the necessary connection information and have you enter the information in the Connection Wizard

With a Connection Key

If you receive the connection key through email, all you have to do is double click on the connection key attachment included in the email.  Contribute will automatically open and initiate the set up process.  

During the set up process, Contribute will stop and ask you to enter: 
1. your name – you may use either your real name, your Unity ID or your Groupwise ID.  Whatever you want people to know you by.

2. email address - you may use any valid email address.  But we suggest that you use your campus email address or whichever email address is best for your to be contacted for business purposes.

3. password for the connection key.  This password is provided by the Contribute administrator.
Note:  If you don’t have a password, contact the Contribute administrator who sent you the connection key.
Note:  Sometimes just double clicking on the connection may not work.

If this happens to you, do the following to create a connection:

Save the Connection Key sent to you by your site administrator. The connection key will be attached to the email from the administrator. It has a “.stc” extension. To save it, right click on the attachment and save it somewhere (perhaps your Desktop). Remember where you saved it.

1. Start Contribute

2. From the main menu, select “Edit”, then

3. Select “My Connections…”

4. On the “My Connections” screen. 

5. Select the “Import….” Button.

6. navigate to the place where you saved the connection key

7. select the connection key

8. select “Open”

9. On the “Import Connection Key” page

a. under “What is your full name?”, enter your real name (i.e., Jane Doe, Jon Dough, etc.)

b. under “What is your e-mail address?”, enter the email address that you want to be contacted for purposes of this website. E.g., yourunityid@ncsu.edu
c. under “What is the connection key password?”, enter your password for this site provided by the site administrator.

d. Select OK.

10. On the “Password” page

a. beside “Username:”, enter your Unity ID

b. beside “Password:”,  enter your Unity Password

c. Select OK

11. The connection will be created – Note: It may take a few seconds to complete this task.

12. On the “My Connections” page

a. Verify that your connection has been created, then

b. Select “Close”.  

The connection to the website has been complete.

Without a connection key

If you do not receive a connection key, you can establish a connection through the “Creating a Contribute website connection” process.  Your Contribute administrator should provide you with the necessary connection information.  You will have you enter the information provided in the Connection Wizard. 
To set up your own connection:

1. Start Contribute

2. On the Contribute Start Page, select on the “Create a Connection”

3. On the Welcome page, select “Next”

4. On the “Website Home Page”, enter the web address (URL) of your website. Or you can browse to the website that you want to connect to. For this class, enter http://www4.ncsu.edu/~yourunityid.

5. Select “Next”

6. On the “Connection Information” page:

a. from the drop down menu under the “How do you connect to your web server?”, select “Secure FTP (SFTP)”

b. under “What is the name of your SFTP server?”, enter “ssh.ncsu.edu”

c. under “What is the “SFTP username?”, enter your Unity ID
d. under “What is the SFTP password?”, enter your Unity password
e. Select “Next”.

7. On the “User Information” screen,

a. under “What is your full name?”, enter your real name (i.e., Jane Doe, Jon Dough, etc.)

b. under “What is your e-mail address?”, enter the email address that you want to be contacted for purposes of this website. E.g., “yourunityid@ncsu.edu”.

8. On the “Summary” page, verify that all entries are correct. If not go back and change them.

9. Select “Done”

You will now be connected directly to your web site. (Note: it may take a few seconds to complete this operation.

 Contact your Contribute Administrator or your departmental Help Desk for assistance.

Connection Problems

Contribute alerts you if it detects a problem with any of your website connections when it launches.  Contribute displays the alert after the first website connection problem it encounters.  You can have Contribute try to connect again.  Just select the “Connect” button at the top of the work area. If Contribute still can’t connect, you can choose to disable the website connection and try to connect to your other websites, if any.  If you disable a website, you can enable it when you resolve your network connection problem.
Deleting a connection with Contribute
To delete a connection:

1. Start Contribute

2. From the main menu, select “Edit”, then

3. Select “My Connections…”

4. On the “My Connections” screen

a. Under “Website name”, select the website to be deleted, then select the “Remove” button. 

5. Verify that you want to remove this connection by selecting the “Yes” button.

6. Select “Close”.  

The connection to the website has been removed.

To reestablish a new connection, use one of the two options above (connecting with a connection key or without a connection key).

Note:  You can choose to disable a website at any time, not just at startup when there’s a problem.  If you have multiple websites, you might choose to disable websites that you aren’t currently working on so that Contribute does not maintain the connection for an extended period of time.  

Disable (or enable) a website: 

From Contribute’s main menu select Edit > My connections… > select the site to be disabled (enabled) > click on the Disable (or Enable) button.
Accessing pages and files

Viewing drafts and new pages

Drafts you are currently editing, and new pages you’ve created but haven’t published yet, appear in the Pages panel.  You can also access these pages using the File menu.
To view a draft or new page
Do one of the following:

1. Click the draft or new page title in the Pages panel in the sidebar.

2. Select File > Drafts, then select a page from the pop-up menu.

Viewing home pages for your websites

· You can use the toolbar to access home pages for websites you’ve connected to. 
· You can also access these pages using the View menu.

To view the home page for a website you’ve connected to
Do one of the following:

· Click the Home Pages button on the toolbar, then select a home page.

· Select View > Home Pages, then select a home page from the pop-up menu.

Viewing recently published pages

You can use the View menu to quickly access pages you’ve recently published.

To view a recently published page:

· Select View > Recently Published Pages, then select a page from the pop-up menu.

Viewing pages and files that you can’t browse to

Contribute enables you to access pages and files associated with your website that you can’t browse to.  Use the Choose button in the toolbar to access pages and files that are saved in a website folder, but aren’t linked from any page on your website.

To view a page or file that is not linked from another page:

1. In the Contribute browser or editor, select View > Choose File on Website or click the Choose button in the browser toolbar.  The Choose File on Website dialog box appears.

2. Select a file by doing one of the following:

· If the file is in a folder on the website you are currently browsing, then select a file.

· If the file is not in a folder on the current website, use the Look In pop-up menu to navigate to the correct website folder, then select a file.  When you select a file, depending on the file type, a preview might appear so that you can be sure you’re selecting the correct file.

3. Click OK.
The page or file appears in the Contribute web browser.

Browsing to a web page

Use the Contribute browser to find the web page you want to edit.  

The browser functions as other web browsers, such as Internet Explorer, and has a familiar look and feel.  

The browser toolbar has the normal navigation buttons, plus a Choose button to help you navigate to files that aren’t linked on your website. 
You can create bookmarks in Contribute and view your Microsoft Internet Explorer bookmarks.  

You can also use shortcuts in the Pages panel in the sidebar to quickly access any current drafts.
Other ways to navigate to web pages

· Click links in web pages to navigate to other pages.

· Type the web address (URL) of the page in the Address text box, then press Enter or click Go.

· Select View > Go to Web Address, enter the web address (URL), then click OK.

Contribute enables you to quickly access the following pages:

· Current drafts or new pages (Click the draft or new page title in the Pages panel in the sidebar or Select File > Drafts, then select a page from the pop-up menu)
· Home pages for the websites you’ve connected to (Click the Home Pages button on the toolbar, then select a home page or Select View > Home Pages)
· Recently published pages (View > Recently Published Pages)
· Pages or files that aren’t linked from another page on your website
· Bookmarks for frequently accessed pages (Select Bookmarks)
Viewing pages and files that you can’t browse to

Contribute enables you to access pages and files associated with your website that you can’t browse to.  Use the Choose button in the toolbar to access pages and files that are saved in a website folder, but aren’t linked from any page on your website.

· To view a page or file that is not linked from another page:

1. In the Contribute browser or editor, select View > Choose File on Website or click the Choose button in the browser toolbar.  The Choose File on Website dialog box appears.

2. Select a file by doing one of the following:

· If the file is in a folder on the website you are currently browsing, then select a file.

· If the file is not in a folder on the current website, use the Look In pop-up menu to navigate to the correct website folder, then select a file.

· When you select a file, depending on the file type, a preview might appear so that you can be sure you’re selecting the correct file.

3 Click OK.

The page or file appears in the Contribute web browser.

Note: If you select a file type that the Contribute browser can’t display, you’ll see the File Placeholder page.
Building Web pages 

You can create and edit any pages on your website, as long as you have permission and as long as someone else is not currently editing the page.  New pages can be created from scratch, from an existing page, using a model page, or using predefined Templates.  
Accessibility features within Contribute

Creating accessible web pages has never been more important than today.  With the recent adoption of the accessibility regulation at NC State, website administrators need to ensure that people with disabilities can easily access their website content.  See:
http://www.ncsu.edu/policies/campus_environ/non-discrimination/REG04.25.5.php
Contribute offers a unique set of tools that allows website administrators to establish and maintain site accessibility.  With accessibility directly integrated into Contribute, website administrators can now specify accessibility settings.  Once these settings have been activated, website content contributors must provide text descriptions for images and identify data-table headings, etc.  In addition, as a website administrator you can also specify whether to use HTML or CSS for text formatting, making it easier for content contributors without any advanced technical knowledge to meet current technical standards.

Contribute administrators set the site’s accessibility options by going to:

Contribute’s main menu > Edit > Administer websites > Permission Groups > Users > Editing > Other editing options and turning on (place a check in) > Enforce accessibility options (such as ALT text for images).  Checking the Enforce Accessibility Options box activates a prompting system for content contributors, requiring them to enter important accessibility information as they insert images and tables on a page.
Note:  It is our strong recommendation that all Contribute administrators turn on all accessibility options and leave them on at all times.
Accessibility and Usability

Accessibility refers to making websites and web products usable for people with visual, auditory, motor, and other disabilities. Contribute provides features that make it accessible to users with disabilities.
Usability is a quality attribute that assesses how easy user interfaces are to use. The word "usability" also refers to methods for improving ease-of-use during the design process.
Although you may not think of “Usability” and “Accessibility” as the same thing, (and technically they are not) they are related and have an impact on each other.  Just as you strive to make your Web pages accessible to persons with disabilities you should also make your Web pages a usable as possible to any visitors.  Both will greatly improve the experience of visits to your Web site.  Visitors come to web sites seeking information.  Make it as easy as possible for them to find the information and make the information as easy as possible to understand. 
Using Style Sheets (CSS) or HTML Tags for formatting

Note:  It is our strong recommendation that all Contribute administrators use CSS styling to control page layout, formatting and presentation of content for each of the media types.
Contribute administrators set the site’s formatting options by going to:

Contribute’s main menu > Edit > Administer websites > Permission Groups > Users > Styles and Fonts > Styles > place a check in - Allow users to apply styles > place a check in - Include CSS style in the Style menu PLUS > Allow users to apply fonts and sizes > place a check in –Inline CSS styles PLUS > (select an appropriate method) Apply sizes using: (%, Ems, etc.).
About Editing

You cannot edit a page if the page is locked—that is, if someone else is currently editing it or if someone else has it “Checked Out”.  When you browse to a page, the message area under the toolbar (the yellow bar) indicates whether you can edit that page.  While you edit a page, Contribute saves it as a draft, and the draft title appears in the Pages panel in the sidebar.  There might be restrictions on which parts of a draft you can edit.  Your website administrator can create a template with locked regions or can set up editing constraints that restrict editing to text only.
Undoing (mistakes?)
In Contribute, as in most applications, you can undo individual mistakes as you make them.  You can also redo an edit if you decide that you don’t want to undo it.

To undo an edit:

· Select Edit > Undo or use CTRL + Z.

To redo an edit:

· Select Edit > Redo or use CTRL + Y.
While in the Edit mode, if you decide that you don’t want to keep any changes, select the “Cancel” button.

Note:  In Contribute, you can also discard changes, after you publish your draft, by reverting to a previously published version of a page if you need to.  For more information, see “Rolling back to a previous version of a page”.

Browsing sites
The easiest way to find a web site or web page is to use Contribute’s web browser.
When you start Contribute, the web sites that are available to you may be selected from the Home Button.
Select a web site from the Home Button.  The index (home) page for the selected web site will appear in Contribute’s Browser window.  Browse to the page that you want to edit.  Select “Edit Page”. 

To go directly to a specific web page within a selected web site, use the “Choose…” (Choose file on website) button.

Creating new pages
Building pages from sample pages and Dreamweaver templates
Copying existing pages
Editing existing pages
To open a page for editing, simply browse to the page or use the Contribute workspace to quickly access special pages.
To edit a page:

1. Browse to a page you want to edit.
2. Do one of the following:

· Click the Edit Page button in the toolbar.

· Select File > Edit Page.
The page appears in the Contribute editor as a draft, and the draft title appears in the Pages panel.
When you find the page you want to edit, you click the Edit Page button to open the page in the Contribute editor. 

Contribute copies the file from your web server and locks it on the server (Check-Out) so that no one else can edit the page while you’re working on it.

You use the Contribute editor as you use a word processor to edit text, images, tables, and links in the page. You can even add a Word or Excel document to your website.  The toolbar contains familiar editing buttons, plus buttons for you to save your edits until later, cancel your edits, or publish your edits to the website.

Setting page properties
Setting page keywords and descriptions
Saving page drafts
Letting coworkers review your pages
Publishing your pages
When you finish editing your page, you are ready to publish the page to your website.  All you have to do is click the Publish button and Contribute replaces the existing page on your web server with your edited version so that it is live on your website.  Contribute also unlocks the file on the server (Check-In) so that other users can edit the page if necessary.
If you do not have “Publishing Privileges”, you can either save the changes as a working Draft or forward it to someone for review.  The recipient may have publishing privileges or can forward it to someone that does.
Rolling back to previous page versions
Printing pages
Previewing pages in external browsers
Exporting HTML pages

Contribute Resources
Stanford School on Medicine – Contribute online training:

http://med.stanford.edu/irt/web/training/contribute/multimedia/
