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Introduction to Excel2007 Part 2

Computing Services Workshops – http://www.ncsu.edu/it/education
Computing Essentials – http://www.ncsu.edu/it/essentials
Instructor: Twanda Baker: Twanda_baker@ncsu.edu
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Materials:

Handout

Exercise Files

Evaluation Sheet

Copy the Exercise files onto the desktop of your computer

1. Double – Click My Computer

2. From the View menu, select List

3. Double-Click the “I:” drive

4. Select ITD - > Excel 

5. Drag the “xl_2” folder to your desktop.

6. Close My Computer
7. Double-click the classinfo.xls file in the xl_2 folder.
Sizing Columns and Rows

Changing column width.
1. Select the column(s).

2. Put your mouse pointer on the column divider, the line to the right of the column heading. Notice the mouse pointer changes to 
[image: image3].

3. Drag the line left to decrease width or right to increase width.

(Exercise 1
In the “Advisor” worksheet, widen the Advisor column.

1. Place your mouse pointer in the gray column header on the line between column A and B.

2. When the mouse pointer looks bold with arrows pointing left and right
[image: image4], click and drag slowly to the right until the column is wide enough to display all of the text.

(Exercise 2
[image: image15.wmf]Widen the Year column. (“Advisor” Worksheet)

1. Double-click the column divider
[image: image5] between columns C and D.

Changing the height of Rows

1. Select the row(s).

2. Put your mouse pointer on the line below the row heading. Notice the mouse pointer changes to [image: image6.bmp] .

3. Drag the line left to decrease width or right to increase width.

(Exercise3
Change the height of several rows at once. (“Advisor” worksheet)
1. Using the gray row header, select rows 1 through 15.
2. Place your mouse pointer on any row divider within the selected area.

3. Drag slowly downward and widen to desired height.

4. Notice all rows in the selected area have been modified.

NOTE: Once column(s) and row(s) have been selected, changing properties such as width and height can also be accomplished through the Formatcommand (on the Home Tab, in the Cells group).

Hiding and Un-hiding Columns and Rows

Hiding

1. Select the row(s) or column(s) you want to hide. (*Remember to use the row and column header).

2. Right-click the Row or Columnheader.

3. Click Hide.
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(Exercise 4
Hide columns G through O using the right-click method. (“Advisor” Worksheet)
1. Select columns G through O using the gray column headers.

2. While pointing in the selected area, right click.

3. Click Hide.

Un-hiding

1. For columns, select the column to the left and the right
of the hidden column(s). For rows, select the row above and below the hidden row(s).

2. Right click anywhere in the selected area.

3. Click Unhide.

4. The hidden column(s) and row(s) will become visible.

(Exercise 5
Unhide columns G through O. (“Advisor” worksheet)
1. Select columns F and P.

2. Right click anywhere in the selected area.

3. Click Unhide.

! NOTE: Hide and Unhide can also be found in the Home Tab, Cells group under Format.
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Worksheet Magnification

Using the Zoom feature

1. Select the View Tab.

2. Click Zoom, from the Zoom group.

3. Select the desired magnification from the Zoom window.

4. Click OK.
(Exercise 6
Magnify the worksheet to 175%, then return the zoom back to normal (100%).(“Advisor” worksheet)
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Look for the Zoom command in the View Tab. (Zoom command is also available at all times on the right side of the status bar. Just click to bring up the Zoom window.)

2. Click on the Custom box and type 175. Click Ok.

3. Observe the changes in the worksheet.

4. Click the 100% command in the Zoom group.

5. Observe the changes in the worksheet.

Magnifying a range of cells

1. Select only the range of cells you’d like to magnify.

2. Select Zoom to Selection in the Zoom group of the View Tab.
(Exercise 7
Magnify a specific set of cells.(“Advisor” worksheet)
1. Select cells A1:E17
2. Click Zoom to Selection in the Zoom group of the View Tab.
3. Change the Zoom back to 100%.

[image: image19.png]urber | Algment | Fort | sordr | pttens [Pt |

W Locked
T~ Hidden

Locking cellsor hiding formulas has no effect unless the
workshest is protected. To protect the worksheet, choose
Protecton from the Tools menu, and then choose Protect
Shest. A password is optional,



Splitting the Screen

1. To divide the worksheet window horizontally, drag the horizontal split box down to the desired row.

2. Use either of the vertical scrollbars to view different areas of the horizontal panes.

3. To divide worksheet the worksheet window vertically, drag the vertical split box to the right to the desired column. 

4. Use either of the horizontal scroll bars to view different areas of the vertical panes.

NOTE: The horizontal split box is located above the vertical scroll bar. The vertical split box is located to the left of the horizontal scroll bar.

Removing the split bars

1. Double-click split bars to remove them.

(Exercise 8
View worksheet with both horizontal and vertical split bars.(“Advisor” worksheet)
1. Drag the horizontal split box down to the middle row on your screen.

2. Use the scroll bars to arrange the information such that the bottom pane starts with the 100th row.

3. Drag the vertical split box to the right to the middle column on your screen.

4. Use the scroll bars to arrange the information such that the right pane starts with the I column.

5. Remove each split bar by double clicking them.
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Freezing and Unfreezing Panes

Freeze Panes 

1. To freeze both row and column headings, click once on the cell directly below the column heading and to the right of the row headings you want to freeze.

2. From the View Tab, Window group select Freeze Panes.
3. Select Freeze Panes again.

Unfreeze Panes

1. From the View Tab, Window group select Freeze Panes.
2. When panes are frozen in your worksheet, the first option under the Freeze Panes command is Unfreeze panes.

3. Select Unfreeze Panes.
(Exercise 9
Freeze the first row of the worksheet so that it’s always showing as the first row when we scroll down.(“Advisor” worksheet)
1. From the View tab, Window group select Freeze Panes.

2. Select Freeze Top Row.

3. Scroll down past the first screen and notice that row 1 remains the top row.

4. Select Unfreeze Panes from the Freeze Panes commands.
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TIP! Navigate between worksheets by right clicking the worksheet navigation buttons [image: image7.png]M4 » M



 to the left of the worksheet tabs.
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Sorting Records

1. Click once inside the column that you want sorted. (* Do NOT select the whole column.*)

2. Look for the Sort and Filter command in the Editing group of the Home tab.

3.  Click 
[image: image8] to sort in ascending order.

4. Click  
[image: image9]to sort in descending order.

(Exercise 10
In the Source Data worksheet, sort by the Order Amount column.

1. Click inside the Order Amount column.

2. Click the Descending Order button 
[image: image10] on the Home tab in Editinggroup.
3. Notice the spreadsheet is now arranged such the largest order amount is at the top and the smallest order amount is at the bottom.

4. Click the Ascending Order button 
[image: image11].

5. Notice the change in the order amount column.

! NOTE: The ascending and descending commands can also be found in the Data tab in the Sort & Filter group. 
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Multi-level Sorting

You can sort by more than one field at once. 

1. From the Data tab select Sort from the Sort & Filter group.

2. In the Sort by box, use the down arrow to select the first field you want sorted. Sort On (a new feature) allows you to choose values, colors or icons. Specify whether you want Ascending (A to Z) or Descending (Z to A) order.

3. Click Add Level to sort by additional fields.
4. Make sure to specify whether your columns have header rows.
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(Exercise 11
In the Advisor worksheet, first sort ascending by Advisor, then descending by Year, then ascending by StudentName.

1. Select Sort from the Data tab.

2. In the Sort bybox click the down arrow and select Advisor.  Sort on Values. Order A to Z.
3. Click Add Level.

4. In the Then by box click the down arrow and select YR. Sort on Values. Ordered from Largest to Smallest.
5. Click Add Level.

6. In the Then by box click the down arrow and select *Student*.  Sort on Values. Order Z to A.
7. Make sure there is a check in the My data has headers box. 
8. Click OK.

Subtotaling a list
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Subtotal sections of your data.

1. Sort list by desired field.

2. Select the Data tab then click Subtotal in the Outline group.
3. In the At each change in use the down pointing triangle to select the field to be subtotaled.

4. In the Use function:box, select the function you prefer.

5. In the Add subtotal to: box, click the check box for each field you’d like totaled.

6. Click Replace current subtotal and Summary below data.
Your workbook will show subtotals in Outline form. Use the Detail level buttons or the Level Symbols to control how much information is displayed. To remove subtotal go to the Data tab, click Subtotalthen click RemoveAll.

(Exercise 12
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Using the Source Data workshop, subtotal the Order Amount for each Salesperson.

1. With the Salesperson column sorted, select the Data tab then click Subtotal.
2. In the At each change in: box use the down pointing triangle to select Salesperson.
3. In the Use function: box, select the SUM function.

4. In the Addsubtotalto:box, click only the Order Amount box.

5. Click OK.

6. Review subtotals, then remove them 
( Data->Subtotal->RemoveAll ). 

Filtering Data

1. Click on any cell in the field to be filtered.

2. From the Data tab, Click Filter.

3. Notice dropdown menus to the right of each column heading.

4. Click the down arrow for the field you want displayed and check the boxes next to the values you want displayed after the filter.

To turn off the AutoFilter feature, go to the Data tab then clickFilter. You’ll notice that the button toggles on and off which each click.

(Exercise 13
Using the Source Data worksheet, use AutoFilter to display all the records where Peacock is the salesperson. Then filter for all the records from the USA.
1. From the Data tab, click Filter.

2. Notice the dropdown menu to the right of each column heading.

3. Click the dropdown menu to the right of the Salesperson column.

4. Click the (Select All) boxed to deselect all the listed values.

5. Click the box next to Peacock, then click OK.
Notice that only the records with Peacock as the Salesperson are displayed.

6. Remove the filter on the salesperson column.

a. Click the dropdown menu to the right of the Salesperson column 

b. Click Clear FilterFrom “Salesperson” .

7. Click the dropdown menu to the right of the Country column.  There are two values, UK and USA.

8. Un-check box UK, leaving a check in the USA box.

9. Notice that only the records from the USA are displayed.

10. From the Data tab, click Clear (Sort & Filtering group) to Clear filters from all the columns in the worksheet.
11. From the Data tab, click Filter to remove the auto-filter arrows from the columns. 

Moving a worksheet between workbooks
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Just like you’d want to have related paper documents in one file folder, it makes sense to put related spreadsheets in the same workbook. The following process will demonstrate how to take a spreadsheet from one workbook and move it to another.

1. Open both workbooks.

2. From the View menu select Arrange All  (Window group).

3. When prompted, select Tiled.

4. Click OK. You should see both workbooks tiled in one window.

5. Using the worksheet tabs at the bottom of the screen, drag the worksheet tab from one workbook to other workbook.  Notice that the worksheet is no longer in its original workbook. (* Tip* To copy the worksheet instead of move it, simply hold down the Ctrl key while you drag.)
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(Exercise 14
Move the Bi-Weekly Timesheet worksheet, from the timesheet.xlsx file, to our classinfo.xls workbook. (Alternate Method)

1. Open timesheet.xlsx. It will be in the exercise folder on your desktop.  Now you have timesheet and classinfo.xlsx workbooks open.

2. Right-click the Bi-weekly timesheet worksheet tab and select Move or Copy. 

3. Under To Book click the down arrow and select classinfo.xlsx 
4. Under Before Sheet select Advisor.

5. Click OK. The Bi-Weekly Timesheet worksheet will be positioned in front of the Advisor worksheet tab in the classinfo workbook.

[image: image28.png]



Formula Review
(Exercise 15
Complete the timesheet by putting appropriate formulas in the following fields: Week 2 Total, Hours Worked, Gross Pay.

1. Click in F27 (Week 2 Total)

2. Click the AutoSum button [image: image13.png]


on Home tab.
3. Press Enter on the keyboard.

4. Click in C31 (Hour Worked)

5. Type =
6. Click F17 (Week 1 Total)

7. Type +
8. Click F27 (Week 2 Total)

9. Press Enter. Notice the sum is calculated in C31 (Hours Worked)

10. Click C32 (Gross Pay).

11. Type = C31 * B31 (This multiplies the Flat Rate and the Hours worked)

12. Press Enter on the keyboard.

13. Format C32 (Gross Pay) to currency style by clicking the 
[image: image14]on the Home tab.

14. Enter fake hours into the timesheet to make sure it calculates properly.
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Protecting a Worksheet

1. Select a set of cells you want to keep editable.

2. Right-click selected cells and select Format Cells.

3. In the Format Cells window, click the Protection tab.

4. Un-check the Locked check box.

5. Repeat steps 1 - 4 to unlock the rest of the cells.

6. From the Tools menu select Protection, then click Protect Sheet. To password protect the worksheet, enter a password in the space provided. However password protection is optional. You can protect the sheet without using a password.

7.  Click OK. Test it out and try to type in a locked cell 

(Exercise 16
1. On the Bi-Weekly Worksheet, select D10:E16.
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Right-click selected cells and select Format Cells.

3. In the Format Cells window, click the Protection tab.

4. Un-check the Locked check box.

5. Repeat steps 1 - 4 to unlock the rest of the cells. D20:E26,E3,C5,F5,H5,B31

6. From the Reviewtab select ProtectSheet. In the space provided, type unlockas the password. ClickOK. Test it out and try to type in a locked cell.

Unprotect a worksheet
From the Review tab, select UnprotectSheet. If the sheet is password protected you will be asked to type in the password. 

3-D Formulas

3-D formulas include cell references from other worksheets in the same or different workbooks. In 3-D formulas the worksheet names are separated from the cell address by an exclamation point (!). 
(Exercise 17
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In worksheets 2003, 2004 and 2005 Buchanan’s sales totals are in the same cell location D12. In this scenario, we can use a 3-D function to Sum D12 across 3 different worksheets. 
1. Click the 3-Year Totals worksheet tab

2. Click B2, the cell which will hold the 3 year total sales for Buchanan.

3. Click the AutoSUM Button. The formula bar should read : =SUM()
4. Click the 2003 worksheet tab.

5. Click cell D12, which holds the total sales by Buchanan for the year 2003.

6. Hold the Shift key down and click the 2004 worksheet tab. Notice how both 2003 and 2003 tabs are selected.

7. Continue to hold down the Shift key and click the 2005 worksheet tab. 

8. Notice the formula bar should read: =SUM('2003:2005'!D12).
9. Press Enter.
(Exercise 18
In the 3-Year Totals worksheet, use a 3-D formula to calculate the total Sale Order Amount each salesperson sold for 2003 – 2005.

1. Click the 3-Year Totals worksheet tab

2. Click B3, the cell which will hold the 3 year total sales for Callahan.

3. Type =
4. Click the 2003 worksheet tab.

5. Click cell D30, which holds the total sales by Callahan for the year 2003.

6. Type +
7. Click the 2004 worksheet tab.

8. Click cell D68, which holds the total sales by Callahan for the year 2004.

9. Type +
10. Click the 2005 worksheet tab.

11. Click cell D40, the cell which holds the total sales by Callahan for the year 2005

12. Press Enter
13. Practice this type of formula by repeating these steps for Davolio.
Coming Soon! Video Tutorial: Creating Labels from an Excel worksheet

Instructions for Creating Labels from an Excel worksheet is will soon be available as a short video tutorial on our website: http://www.ncsu.edu/it/education/  under Faculty-Staff  and Help Yourself.
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