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Computing Services Workshops – http://www.ncsu.edu/it/education
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Materials:

Handout

Exercise Files

Copy the Exercise files onto the desktop of your computer

1. Double – Click My Computer

2. From the View menu, select List

3. Double-Click the “I:” drive

4. Select ITD - > Excel 

5. Drag the “xl_3” folder to your desktop.

6. Close My Computer
Arranging Columns using Sort
There may be times where you need to change the column order of your spreadsheet. There are 2 ways to do this; you could select a whole column, then cut and paste cut cells or you can sort by column. Sorting by column, requires that you place a number in at the top of each column. That number represents the order in which that column should appear in your spreadsheet. This may require that you insert a row above the field name. Once the Columns are numbered, perform a sort using the option to sort left to right.

( Exercise 1 

Using the Sort by Column method, arrange the grade data so that the fields are in the following order: Student Id, Midterm, Final Essay ,Final Mult. Choice and Final Course Score.

1. Go to the grades sheet of the classinfo.xlsx workbook.

2. Insert a row above the header row. Right-click row 1 and select insert.
3. Place a 1 above the field name that should be positioned as the first column.(studentID)

4. Place a 2 above the field name that should be positioned as the second column.(Midterm)

5. Place a 3 above the field name that should be positioned as the third column.(Final Essay)

6. Place a 4 above the field name that should be positioned as the fourth column.(Final Mult. Choice)

7. Place a 5 above the field name that should be positioned as the fifth column.(CourseGrade)

8. From the Data tab select Sort, then click Options…
9. In the Sort Options box, under orientation, select Sort left to right. Click OK

10. Select to sort by row 1 in Ascending order (smallest to largest).

11. Delete row 1. Rt-click the row header for the first row and select Delete.

Dividing a Column

It’s a good policy to break down data into it’s smallest component. If you have an excel database of addresses where there’s a name column that includes both first and last names, it is best to divide the column resulting in a first name column and a last name column. This would allow you sort by last name or even first name if you like. When you encounter data that needs to be divided into separate columns, use Excel’s “text to column” feature.

( Exercise 2 

We are going to change the grading scale such that the letter grades associated with the Final Course Score field will change. Using the grades table we imported from the web, separate the letter grades into their own column.
1. Select the column header for the column that needs to be separated (Column E). 

2. From the Data tab, select Text to Columns  from the Data Tools group. 

3. Select Delimited in step 1 of 3. This data can’t be properly separated by a fixed column length. If you tried split the column with a line straight down, you would cut of the score and or the letter grade for some rows. 

4. We want the Final Course Score column to split between the number score and the letter grade. Since the score and the grade are separated by a space in every instance, select the Space option in Step 2 of 3. 

5. In Step 3 of 3, in the Destination box, note the Destination cell. This is where the divided columns will be placed. Click Finish. 

6. Right click the column header that contains letter grades, then select delete. [image: image3.png][Convert Text to Columns Wizard - Step 3 of 3
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Tip! If we were splitting a column positioned at the beginning or the middle of our data, we would need to create a blank column before the column to be divided. Otherwise you could write over a column of data.

Conditional Formulas

If functions provide a value based on a condition you specify. It is structured as follows:

=IF(conditional test, value if true, value if false)

( Exercise 3 
In a fictional Pass/Fail course, students must make a final grade of 60 or greater to pass the course, otherwise they fail. Use an If function to enter “Pass” or “Fail” in column F.

1. In f2 enter: =If(e2>=60, “Pass”, “Fail”)
2. Copy this formula down the whole column. Right-click F2, select copy. Select the rest of the cells in column F. Right-click selected cells, click Paste.
( Exercise 4 
In the previous example we specified “60” in our formula as the score needed to pass the course. If we later decided to change the passing score to something else, we’d have to make that change in each formula. We can avoid this problem by referring to another cell instead of using an actual number. This way, if we decide to change the score required to pass, we could make the change in one place and all the records would be affected. 

Designate cell H2 to contain the Passing Grade, Change the Conditional formula used in the previous exercise such that it reference H2 instead of 60. Copy the formula and paste it to the remaining rows.

1. In cell H1 type, Passing Grade. 

2. In cell H2 type, 60.

3. Modify the formula in cell F2 (the Grades column) to =If(e2>=H2, “Pass”, “Fail”)
4. Copy this formula down the whole column. Right-click F2, select copy. Select the rest of the cells in column F.  Right-click selected cells, click Paste. The Grades should have stayed the same since we didn’t change the score required to pass. However, notice how everyone is now passing the course.

5. Click cell F3 and look at the formula in the formula bar. Notice how it no longer references H2 but H3.

6. Click cell F3 and look at the formula in the formula bar. Notice how it no longer references H2 but H4.

The feature that adjusts a formula as it is copied across a row or down a column is no longer working in our favor. To force the formula to reference H2 in every case, we need to create an absolute reference to H2 in formula, then copy it to the remaining rows.

Absolute and Relative References

When formulas with relative cell references are copied, its cell references adjust to its new location. Absolute cell references don’t change when its formula is copied. A dollar sign ($) typed before the column letter and before the row number creates an absolute cell reference. Pressing the [F4] key repeatedly toggles you through each of the four types of cell references.

	Cell Entry
	Type of Referencing
	Result

	C1
	Relative
	Both the row and column will change when copied to another location.

	$C1
	Mixed
	The column will not change when copied to another location, but the row will.

	C$1
	Mixed
	The row will not change when copied to another location, but the column will.

	$C$1
	Absolute
	The column and the row will not change when copied to another location.


( Exercise 5
1. Double click cell F2.

2. Move the insertion point to the reference that needs to be made absolute (in-between the H and the 2).

3. Press the F4 key until H2 looks like $H$2 (only takes one press, but go ahead and toggle through the other options until you get back to the one we want).

4. Press the Enter key.

5. Copy this formula down the whole column. Right-click F2, select copy. Select the rest of the cells in column F.  Right-click selected cells, click Paste.
Nested IF functions

When more than one condition must be tested, nested If functions may be used (up to 7 conditions deep).

=IF(conditional test, value if true, If(conditional test 2, value if true, value if false)).
( Exercise 6 

In an alternative Pass/Fail grading system, student can earn a “Pass”, “D” or “Fail”. Write a nested if statement that enters “Pass” for grades above 69, enters “Fail” for grades less than 60 and a “D” for anything in-between.

1. In H2 type, 69
2. In I1 type Failing if below.

3. In I2, type the score for failing, 60  

4. In cell F2 enter, =If(e2>$H$2, “Pass”, If(e2<$I$2, “Fail”, “D”))
5. Copy this formula down the whole column. Right-click F2, select copy. Select the rest of the cells in column F. Right-click selected cells, click Paste.
 
Creating Custom Views 

Filter data different ways and save the results in various custom views

( Exercise 7 : Create a custom view for the original state of this worksheet. 
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Using the same workbook, go to the Advisor worksheet.

2. From the Data tab, select Filter.

3. Widen the A and C columns. 

4. From the View tab, select Custom Views from the Workbook views group.

5. Click the Add button and type, Original, Click OK.
( Exercise 8 : Filter data to show only records where either “Boone” or “Chase”  is the advisor and save the filtered data as a custom view called “BooneChase” 

1. With the filter feature enabled, click the down arrow next to the Advisor column, click Select All to deselect the values in the list. 

2. Put a check in the boxes for Boone and Chase.

3. Create a custom view for the filtered state of this worksheet. 

4. From the View tab, select Custom Views.

5. Click the Add button and type, BooneChase  

6. Click OK
( Exercise 9 : On your own. Filter data to show only records where “Amos” is the advisor and save the filtered data as a custom view called “Amos”

1. With the filter feature enabled, click the down arrow next to the Advisor column and select only Amos.
2. Create a custom view for the filtered state of this worksheet. 

3. From the View tab, select Custom Views.

4. Click the Add button and type, Amos.

5. Click OK.
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( Exercise 10 : Switch between custom views

1. From the View tab, select Custom Views.

2. Click on one of the views listed, then click Show.

3. Repeat steps 1 & 2, to select other views
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Automating Tasks using Macros

( Exercise 11 : Record a macro that will switch to the Original view via a keyboard shortcut.

1. From the View tab, select Macros, then click Record a Macro. 

2. In the Record Macro window, use Original as the Macro name.

3. Click in the Shortcut Key text box, hold down the [Shift] and the letter O.
4. Select This workbook from the Store macro in drop down menu.

5. Click OK. As soon as you click OK Excel will record your keystrokes and mouse clicks. Follow the next steps exactly as listed. Otherwise, Excel will record your mistakes. (Don’t worry we can always delete our Macro and start over.) 

6. From the View menu, select Custom Views.

7. Click on Original, then click Show.

8. From the View tab, select Macros, then click Stop Recording. 

9. Now whenever you press [Ctrl] + [Shift] + O, the custom view, Original displays. 

( Exercise 12 : Create macros to display other custom views. (Use steps in Exercise 12)
1. Create a macro to show the BooneChase custom view when you use the [Ctrl] + [Shift] + B keyboard shortcut.

2. Create a macro to show the Amos custom view when you use the [Ctrl] + [Shift] + A keyboard shortcut. 

3. Test the three macros to make sure they work


 If you find that your macro doesn’t work. I recommend that you delete the macro and start again.

( Exercise 13: Deleting a Macro

1. From the View tab, select Macros, then select View Macros.

2. From the Macros list, select the Macro you want to delete.

3. Click the Delete Button.

Customize Quick Access Toolbar

Office 2007 gives you the power to customize your Quick Access Toolbar. You can determine which commands (including macros) appear.  
( Exercise 14: Customize Quick Access Toolbar with a Macro
1. Click the More button at the end of the Quick Access Toolbar and choose More Commands. [image: image4.png]



2. From the Choose Commands from box select Macros. A list of available Macros appears.
3. Double click each macro you created in the class. Double-clicking moves the macro to the right column (representing your Quick Access Toolbar).

4. To change the icon of any command, Select the command in the right column then click the Modify button for a gallery of icon alternatives. 

1. Click OK to accept all changes to the Quick Access Toolbar. Simply click the toolbar name so that it is highlighted), then click Delete.
Create Drop-Down Lists in a cell

( Exercise 19 

Create a drop down list to enter the responses to a survey.

1. Go to the Survey sheet to see the short class evaluation form.

2. Go to the dropdown sheet. This sheet lists the possible responses we need to enter in the second column of the Survey sheet.

3. Select the list (cells A1:A5). If there is a column header do not include it in the selection. 

4. Right-click the selection and click Name a Range.

5. In the New Name box, type response as the name, then click OK.

6. Click on the Survey sheet and select cells B2 through B5.

7. Under the Data tab, select Data Validation.
8. In the Settings tab under Allow: select List. Make sure ignore blank and In-Cell dropdown is checked.

9. In the Settings tab under Source type, =response   I choose to use “response” as the list name, you can use any name just stick with letters and don’t include spaces. You must include the = sign before the list name.

10. Notice that you could also include Input Messages and Error Alerts.  These options allow you to communicate with the user when they attempt to enter data into a cell with data validation. 
11. Click OK.

12. Click inside cell B2. Notice the dropdown arrow and options available.
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