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Introduction to Excel Part 3

Computing Services Workshops – http://www.ncsu.edu/it/education
Computing Essentials – http://www.ncsu.edu/it/essentials
Instructor: Twanda Baker: Twanda_baker@ncsu.edu
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Materials:

Handout

Exercise Files

Evaluation Sheet

Copy the Exercise files onto the desktop of your computer

1. Double – Click My Computer

2. From the View menu, select List

3. Double-Click the “I:” drive

4. Select ITD - > Excel 

5. Drag the “xl_3” folder to your desktop.

6. Close My Computer
Importing Data from the Web

These days any information worth anything is available online. Excel’s import data feature enables you to take advantage of this by allowing you to snatch a table of data from the web and pull it into an Excel spreadsheet.

( Exercise 1
Import a table of student grades from the following webpage http://www.ncsu.edu/it/education/training/excel/grades.html
1. Open a new Excel spreadsheet if necessary.

2. From the Data menu, point to Import External Data, then New Web Query.

3. In the New Web Query box, type in the web address of the site with the data you will import. For this example type: http://www.ncsu.edu/it/education/training/excel/grades.html and press the “ENTER” key.

4. Click the arrow [image: image3.bmp] to select the table. A [image: image4.bmp] indicates that the table is selected for import.

5. Click the “Import” button at the bottom right corner of the window.

6. When it asks where to put the imported data, click cell A1, if necessary
7. Click the Properties button.

8. Uncheck the “Save query definition” box. If we wanted to be able to check the original web page and update the table data we would leave this box checked. For this example, we do not want the data to remain connected to the original website.

9. Click “OK” to get out of the Properties box

10. Click OK to import the data.

Arranging Columns using Sort
There may be times where you need to change the column order of your spreadsheet. There are 2 ways to do this; you could select a whole column, then cut and paste cut cells or you can sort by column. Sorting by column, requires that you place a number in at the top of each column. That number represents the order in which that column should appear in your spreadsheet. This may require that you insert a row above the field name. Once the Columns are numbered, perform a sort using the option to sort left to right.
( Exercise 2 

Using the Sort by Column method, arrange the grade data so that the fields are in the following order: Student Id, Midterm, Final Essay ,Final Mult. Choice and Final Course Score.

1. Insert a row above the header row. Right-click row 1 and select insert.
2. Place a 1 above the field name that should be positioned as the first column.(studentID)

3. Place a 2 above the field name that should be positioned as the second column.(Midterm)

4. Place a 3 above the field name that should be positioned as the third column.(Final Essay)

5. Place a 4 above the field name that should be positioned as the fourth column.(Final Mult. Choice)

6. Place a 5 above the field name that should be positioned as the fifth column.(Final Course Score)

7. From the Data menu select Sort, then click Options…
8. In the Sort Options box, under orientation, select Sort left to right. Click OK

9. Select to sort by row 1, Ascending.

10. Delete row 1. Rt-click the row header for the first row and select Delete.

Dividing a Column

It’s a good policy to break down data into it’s smallest component. If you have an excel database of addresses where there’s a name column that includes both first and last names, it is best to divide the column resulting in a first name column and a last name column. This would allow you sort by last name or even first name if you like. When you encounter data that needs to be divided into separate columns, use Excel’s “text to column” feature.

( Exercise 3 

We are going to change the grading scale such that the letter grades associated with the Final Course Score field will change. Using the grades table we imported from the web, separate the letter grades into their own column.
1. Select the column header for the column that needs to be separated (Column E). 

2. From the Data menu, select Text to Columns. 

3. Select Delimited in step 1 of 3. This data can’t be properly separated by a fixed column length. If you tried split the column with a line straight down, you would cut of the score and or the letter grade for some rows. 

4. We want the Final Course Score column to split between the number score and the letter grade. Since the score and the grade are separated by a space in every instance, select the Space option in Step 2 of 3. 

5. In Step 3 of 3, in the Destination box, select cell F1, and click Finish. 
6. Right click the column header that contains letter grades, then select delete.

Tip! If we were splitting a column positioned at the beginning or the middle of our data, we would need to create a blank column before the column to be divided. Otherwise you could write over a column of data

Conditional Formulas

If functions provide a value based on a condition you specify. It is structured as follows:

=IF(conditional test, value if true, value if false)

( Exercise 4 
In a fictional Pass/Fail course, students must make a final grade of 60 or greater to pass the course, otherwise they fail. Use an If function to enter “Pass” or “Fail” in column F.

1. In f2 enter: =If(e2>=60, “Pass”, “Fail”)
2. Copy this formula down the whole column. Right-click F2, select copy. Select the rest of the cells in column F. Right-click selected cells, click Paste.
( Exercise 5 
In the previous example we specified “60” in our formula as the score needed to pass the course. If we later decided to change the passing score to something else, we’d have to make that change in each formula. We can avoid this problem by referring to another cell instead of using an actual number. This way, if we decide to change the score required to pass, we could make the change in one place and all the records would be affected. 
Designate cell H2 to contain the Passing Grade, Change the Conditional formula used in the previous exercise such that it reference H2 instead of 60. Copy the formula and paste it to the remaining rows.

1. In cell H1 type, Passing Grade. 

2. In cell H2 type, 60.

3. Modify the formula in cell F2 (the Grades column) to =If(e2>=H2, “Pass”, “Fail”)
4. Copy this formula down the whole column. Right-click F2, select copy. Select the rest of the cells in column F. Right-click selected cells, click Paste. The Grades should have stayed the same since we didn’t change the score required to pass. However, notice how everyone is now passing the course.

5. Click cell F3 and look at the formula in the formula bar. Notice how it no longer references H2 but H3.

6. Click cell F3 and look at the formula in the formula bar. Notice how it no longer references H2 but H4.

The feature that adjusts a formula as it is copied across a row or down a column is no longer working in our favor. To force the formula to reference H2 in every case, we need to create an absolute reference to H2 in formula, then copy it to the remaining rows.
Absolute and Relative References

When formulas with relative cell references are copied, its cell references adjust to its new location. Absolute cell references don’t change when its formula is copied. A dollar sign ($) typed before the column letter and before the row number creates an absolute cell reference. Pressing the [F4] key repeatedly toggles you through each of the four types of cell references.

	Cell Entry
	Type of Referencing
	Result

	C1
	Relative
	Both the row and column will change when copied to another location.

	$C1
	Mixed
	The column will not change when copied to another location, but the row will.

	C$1
	Mixed
	The row will not change when copied to another location, but the column will.

	$C$1
	Absolute
	The column and the row will not change when copied to another location.


( Exercise 6
1. Double click cell F2.

2. Move the insertion point to the reference that needs to be made absolute (in-between the H and the 2).

3. Press the F4 key until H2 looks like $H$2 (only takes one press, but go ahead and toggle through the other options until you get back to the one we want).

4. Press the Enter key.

5. Copy this formula down the whole column. Right-click F2, select copy. Select the rest of the cells in column F. Right-click selected cells, click Paste.
Nested IF functions

When more than one condition must be tested, nested If functions may be used (up to 7 conditions deep).

=IF(conditional test, value if true, If(conditional test 2, value if true, value if false)).
( Exercise 7 

In an alternative Pass/Fail grading system, student can earn a “Pass”, “D” or “Fail”. Write a nested if statement that enters “Pass” for grades above 69, enters “Fail” for grades less than 60 and a “D” for anything in-between.

1. In H2 type, 69
2. In I1 type Failing if below.
3. In I2, type the score for failing, 60  

4. In cell F2 enter, =If(e2>$H$2, “Pass”, If(e2<$I$2, “Fail”, “D”))
5. Copy this formula down the whole column. Right-click F2, select copy. Select the rest of the cells in column F. Right-click selected cells, click Paste.

[image: image8.wmf]Creating Custom Views

( Exercise 8 : Filter data different ways and save the results in various custom views 

1. Open customviews.xls.

2. From the Data menu, select Filter, then click AutoFilter.

3. Create a custom view for the original state of this worksheet. 
4. From the View menu, select Custom Views.

5. Click the Add button and type, Original  

6. Click OK
( Exercise 9 : Filter data to show only records where “Sparks” is the advisor and save the filtered data as a custom view called “Sparks” 
1. With the Auto-filter feature enabled, click the down arrow next to the Advisor column and select Sparks
2. Create a custom view for the filtered state of this worksheet. 

3. From the View menu, select Custom Views.

4. Click the Add button and type, Sparks  

5. Click OK
( Exercise 10 : On your own. Filter data to show only records where “Amos” is the advisor and save the filtered data as a custom view called “Amos”

1. With the Auto-filter feature enabled, click the down arrow next to the Advisor column and select Amos
2. Create a custom view for the filtered state of this worksheet. 

3. From the View menu, select Custom Views.

4. Click the Add button and type, Amos.
5. Click OK.
( Exercise 11 : Switch between custom views
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1. From the View menu, select Custom Views.

2. Click on one of the views listed, then click Show.
3. Repeat steps 1 & 2, to select other views
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Automating Tasks using Macros
( Exercise 12 : Record a macro that will switch to the Original view via a keyboard shortcut.

1. From the Tools menu, select Macro, then click Record a Macro. 
2. In the Record Macro window, use Original as the Macro name.
3. Click in the Shortcut Key text box, hold down the [Shift] and the letter O.
4. Select This workbook from the Store macro in drop down menu.

5. Click OK. As soon as you click OK Excel will record your keystrokes and mouse clicks. Follow the next steps exactly as listed. Otherwise, Excel will record your mistakes. (Don’t worry we can always delete our Macro and start over.) 
6. [image: image11.png]Macro name:
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From the View menu, select Custom Views.

7. Click on Original listed, then click Show.

8. Click the stop button (square) on the floating Macro recorder window.

9. You have just recorded a macro. Now whenever you press [Ctrl] + [Shift] + O, the custom view, Original displays.
( Exercise 13 : Create macros to display other custom views. (Use steps in Exercise 12)
1. Create a macro to show the Sparks custom view when you use the [Ctrl] + [Shift] + S keyboard shortcut.

2. Create a macro to show the Amos custom view when you use the [Ctrl] + [Shift] + A keyboard shortcut. 
3. Test the three macros to make sure they work
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If you find that your macro doesn’t work. I recommend that you delete the macro and start again.
( Exercise 14: Deleting a Macro
1. From the Tools menu, select Macro, then click Macros.

2. From the Macros list, select the Macro you want to delete.

3. Click the Delete Button.

Customize Toolbars

MS Word gives you the power to personalize your toolbars. You can determine which commands (including macros) appear in any existing (or new) toolbar.  That’s right, you can even create your own personalize toolbar with your favorite commands.

( Exercise 15: Customize Toolbars
1. From the Tools menu, click Customize. This opens the Customize window. You must have the Customize window open before you can customize any toolbar.
2. With the Customize window open you can:

a. Rearrange icons around within a menu or toolbar

b. Move icons onto another menu or toolbar 

c. Drag icons off a menu or toolbar and into the work area to remove them completely

NOTE: You’ll want to be very careful as you make changes to commonly used toolbars.

3. Click and drag the Save icon [image: image5.bmp] beside the print icon [image: image6.bmp] (on the standard toolbar). 
4. Drag the Save icon completely off of the toolbar into your work area (spreadsheet area). This removes the icon from its toolbar.

5. Now, let’s put the Save icon back in place. With the Commands tab selected, click File from the Categories: section, then scroll to Save in the Commands: section.
6. Drag the save icon from the Customize window back to its original location on the standard toolbar. [image: image7.png]EdR A



 Now you know how to put any command on any toolbar. What especially great is that this exact procedure is used to manipulate toolbars in MS Word.
( Exercise 16: Creating your own toolbar and adding your macros
1. From the Tools menu, select Customize.

2. Click the Toolbars tab, then click New.

3. This will be your personal toolbar, give it the title MyToolbar, then click OK. The empty toolbar displays as small box. It will expand as you add items to it. After the Customize window is closed, you will be able to drag any side of your toolbar to expand it.
( Exercise 17: Add macros to your personal toolbar
1. Make sure your toolbar (named MyToolbar) is displayed. Click the Commands tab of the Customize window. 
2. In the Categories: section scroll down and select Macros.

3. Drag Custom Menu Item from the Commands: section onto MyToolbar.

4. Right-click Custom Menu Item now on MyToolbar. Notice the options available on this menu.
5. Select Assign Macro. 
6. An Assign Macro window will appear. Select one of the macros you created, then click OK.
7. Now right-click Custom Menu Item on MyToolbar, select the  Name: text box and enter an appropriate name for this button on your toolbar.
8. Close the Customize window.
( Exercise 15: Customize Toolbars
( Exercise 19: Deleting your toolbar (disclaimer: I can not be held responsible if you delete a major toolbar. *smile*)
Please follow these instructions carefully so that you only delete the toolbar you created.
1. Select Customize from the Tools menu.

2. Select the Toolbar tab is necessary.

3. Scroll down to the bottom of the list of toolbars until you find the one you created.

4. Select your toolbar (simply click the toolbar name so that it is highlighted), then click Delete.
Create Drop-Down Lists in a cell
( Exercise 20 

Create a drop down list to report the status of an invoice.

1. Using invoice.xls, click on the Status sheet. This sheet lists the possible statue values we want in the drop down list.

2. Select the list not including the column header. Select A2:A4.

3. From the Insert menu, point to Name¸ then select Define.

4. In the Define Name box, type Status in Names in workbook section, click OK.

5. Click on the Invoice sheet and click on E8, the cell where the status value should be.
6. Under the Data menu, select Validation.
7. In the Settings tab under Allow: select List. Make sure ignore blank and In-Cell dropdown is checked.

8. In the Settings tab under Source type, =Status.
9. Notice that you could also include Input Messages and Error Alerts.

10. Click OK.

11. Click inside E8. Notice the dropdown arrow.

Bonus Exercise 1: Pivot Tables

A Pivot Table is an interactive table that organizes and summarizes large amounts of data. You choose what fields you want summarized and the table changes to match your request.

( Exercise 21
A Parking Deck Attendant is responsible for collecting money from 3 different parking meters in a large parking deck. At the end of every weekday, the Attendant must record a breakdown of all currency collected from each meter. At the end of the week, the Attendant must create at least 2 reports:

1 - Show how much money each meter collected each day of the week. 

2 – Show the breakdown of currency collected from each meter on each day of the week

Create these reports using Pivot Tables.

1. Open PivotTables.xls
2. From the Data menu, select Pivot Tables & Pivot Chart Wizard..

3. Select Excel List or Database and Pivot Table, then click Next.

4. Scroll to make sure all your data is selected. The Range should be $A$1:$D$101. If not select data now and click Next.

5. Select to put the Pivot Table in a new worksheet, then click LAYOUT.

6. Since our first report much show how much money was collected from each meter each day, we’ll layout a Pivot Table with the days of the week listed down in a row and meters 1-3 listed horizontally across the top of the table. 
Drag the Day field on top of the row section of the diagram.

7. Drag the Meter# field on top of the column section of the diagram..

8. Drag the amount field in the data section of the diagram..

9. Click OK, then click Finish. (Notice that the Pivot Table is displayed in a new worksheet and that the Pivot Table toolbar is floating in the document.)

10. Modify the report to show only Meters 1 & 3. Click the Down arrow next to the Meter# field at the top of the Pivot Table, un-check the other Meters, then click OK. Notice the changes that occur in the table. 

11. Now use the same technique to put Meters 2 & 4 back on the table. Notice that Days of the week can also be filtered out.

12. To change the layout and create a different report, find the Pivot Table toolbar and click Pivot Table, then Wizard.

13. Click Layout.

14. Drag the Meter # field from its location to any gray area to take it out of the layout.

15. Replace it with the Currency field.

16. Click OK, then Finish. Notice the difference in the report.

17. Now make one final change to the layout of your Pivot Table. Using the Meter# field button on the Pivot Table toolbar, drag the field to row1 which is labeled in gray, “Drop Page Fields Here”. Now you can use the drop down options to filter out data for specific Meters.

Bonus Exercise 2: Looking up Values in Large Databases

Using Lookup functions is one way to return a value from your table by looking up another value in that table. VLookup, is used to look up values listed vertically in columns. When using VLookup you must sort (ascending) your lookup column for the lookup function to work properly in all cases. The lookup column must also be the first column in it’s spreadsheet. Vlookup functions look like this:  =Vlookup(10,A2:F17,3,false)  This function looks for the number 10 in the first column of the range A2 through F17. If it finds the 10, this function returns the value in the 3rd column of that row. False means you only want to return a value on an exact match of 10. If there was no 10 in the data, an error message is returned. If “True” were the last value and 10 was not in the data, the function would look for the next lowest value and return the value in the 3rd column of that row.

( Exercise 22 
Use the Vlookup function to lookup an item # and return the item description. 
1. Open invoice.xls
2. In the Invoice sheet, enter, “DK-23” in cell B18.
3. Click in cell C18. Click the fx button in the formula bar to get help from the formula wizard.

4. Search for and select the vlookup function.

5. Click once inside the Lookup_value box then click B18.
6. Click once inside the Table_array box then use your mouse to select the range of data from the InventoryList sheet A2 through D89.
7. Click one in the Col_index_num box and enter 3. 

8. Click in the Range_lookup box and type “false”.

9. Click OK.

10. Edit the formula in C18 such that it uses absolute references. It should look like this: =VLOOKUP(B18,InventoryList!$A$1:$D$89,3,FALSE)

11. Copy and paste this modified formula down the row to C30.

12.  In cells B19 – A30, enter a Supply Item # from attached sheet and see their descriptions show up in column C.

( Exercise 23 
Use the Vlookup function to lookup the unit price of a supply item.

1. Open invoice.xls
2. In the Invoice sheet, enter, “DK-23” in cell B18 if necessary.
3. Click in cell D18. Click the fx button in the formula bar to get help from the formula wizard.

4. Search for and select the vlookup function.

5. Click once inside the Lookup_value box then click B18.
6. Click once inside the Table_array box then use your mouse to select the range of data from the InventoryList sheet A2 through D89.
7. Click one in the Col_index_num box and enter 4. 

8. Click in the Range_lookup box and type “false”.

9. Click OK.

10. Edit the formula in D18 such that it uses absolute references. It should look like this: =VLOOKUP(B18,InventoryList!$A$1:$D$89,4,FALSE)

11. Copy and paste this modified formula down the row to D30.

12.  In cells B19 – A30, enter a Supply Item # from attached sheet and see their unit prices appear in column D.


TIP! Give your spreadsheet a graphical background. From the Format menu, select Sheet, then select Background. Choose a background image from your files.


TIP! Hide the spreadsheet with the inventory list. From the Format menu, select Sheet, then select Hide. To unhide go back to Format>Sheet>select Unhide.

Catalog for Lookup Exercise:
	Item #
	Category
	Item Description
	Price/Unit

	BR-1
	Breakroom
	3-hole binders
	 $                 1.90 

	BR-2
	Breakroom
	3-hole punch
	 $                43.94 

	BR-3
	Breakroom
	Appointment book
	 $                10.70 

	BR-4
	Breakroom
	At-a-Glance wall calendar
	 $                 9.50 

	BR-5
	Breakroom
	Blotter
	 $                 8.35 

	BR-6
	Breakroom
	Bookcase
	 $              350.00 

	BR-7
	Breakroom
	Bulletin board
	 $                40.00 

	DK-1
	Desktop
	Calculator
	 $              163.00 

	DK-10
	Desktop
	Clock
	 $                19.53 

	DK-11
	Desktop
	Coffee maker
	 $                30.00 

	DK-12
	Desktop
	Computer - Apple/Mac - desktop
	 $           2,965.00 

	DK-13
	Desktop
	Computer - Apple/Mac - laptop
	 $           3,470.00 

	DK-14
	Desktop
	Computer - IBM clone - desktop
	 $           1,000.00 

	DK-15
	Desktop
	Computer - IBM clone - laptop
	 $           1,899.00 

	DK-16
	Desktop
	Copy holder
	 $                24.94 

	DK-17
	Desktop
	Desk
	 $              525.00 

	DK-18
	Desktop
	Desk lamp
	 $                76.60 

	DK-19
	Desktop
	Fan
	 $                36.48 

	DK-2
	Desktop
	Calendar - Desktop, large
	 $                10.39 

	DK-20
	Desktop
	Fax machine  
	 $              300.00 

	DK-21
	Desktop
	Fax machine plus
	 $              457.83 

	DK-22
	Desktop
	File cabinet 2-drawer
	 $              112.16 
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