
 
 

Excel II 
 

Welcome to Student Computing Education! 
• Information Technology Division (ITD) – http://itd.ncsu.edu 
• Computing Services (CS) – http://www.ncsu.edu/it/essentials 
• Student Education – http://www.ncsu.edu/it/education/students 

 
Instructor: 
Twanda Baker – twanda_baker@ncsu.edu 
 
Handout written by Twanda Baker 
 
Objectives: 
 

• Sizing Columns and Rows 
• Hiding and Unhiding Columns and Rows 
• Worksheet Magnification 
• Freezing and Unfreezing Panes 
• Finding Records 
• Sorting Records 
• Filtering Data 
• Formula Review 
• 3-D Formulas 
• Conditional Formulas 
• Absolute and Relative References 
• Nested “IF” Functions 
• Password Protecting your Workbook 

Materials: 

1. Double-Click My Computer  (The computer icon your desktop) 
2. Double-Click the I drive (I://) and navigate to the ‘Student_Ed’ folder 
3. Double-Click Excel I (you may want to consider copying this to your desktop) 
4. Double-Click to open student_excel2.xls 

 
Evaluation: 

Please evaluate this class by going online within 24 hours of the end of class to 
http://www.ncsu.edu/it/education/students/evaluations . 

Thank you!  
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Sizing Columns and Rows 
 
Changing column width 

1. Select the column(s). 
2. Put your mouse pointer on the column divider, the line to the right of the column 

heading. Notice the mouse pointer changes to . 
3. Drag the line left to decrease width or right to increase width. 

 
 Exercise 1 

In the “Advisor” worksheet, widen the Advisor column. 
1. Place your mouse pointer in the gray column header on the line between column 

A and B. 
2. When the mouse pointer looks bold with arrows pointing left and right  , click 

and drag slowly to the right until the column is wide enough to display all of the 
text. 

 

 Exercise 2  

Widen the Year column. (“Advisor” Worksheet) 
1. Double-click the column divider  between columns C and 

D.  
 
Changing the height of Rows 

1. Select the row(s). 
2. Put your mouse pointer on the line below the row heading. Notice the mouse 

pointer changes to  . 
3. Drag the line left to decrease width or right to increase width. 

 

 Exercise 3  

Change the height of several rows at once. (“Advisor” worksheet) 
1. Using the gray row header, select rows 1 through 15. 
2. Place your mouse pointer on any row divider within the selected area. 
3. Drag slowly downward and widen to desired height. 
4. Notice all rows in the selected area have been modified. 
NOTE: Once column(s) and row(s) have been selected, changing properties such as 
width and height can be accomplished through the Format menu. 
 

Hiding and Unhiding Columns and Rows 
 

Hiding 
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1. Select the row(s) or column(s) you want to hide. (*Remember to use the row and 
column selector). 

2. Under the Format menu select either Row or Column. 
3. Click Hide. 

 Exercise 4  

Hide columns G through O using the right-click 
method. (“Advisor” Worksheet) 

1. Select columns G through O using the gray 
column headers. 

2. While pointing in the selected area, right-click. 
3. Click Hide.  

 
Unhiding 

1. For columns, select the column to the left and 
the right 
of the hidden column(s). For rows, select the 
row above and below the hidden row(s). 

2. In the Format menu select column or row. 
3. Click Unhide. 
4. The hidden column(s) and row(s) will become visible. 

 

 Exercise 5  

Unhide columns G through O. (“Advisor” worksheet) 
 

1. Select columns F and P. 
2. From the Format menu select Column 
3. Click Unhide. 
 

Worksheet Magnification 
 
Using the Zoom feature 

1. Select the View menu. 
2. Select Zoom. 
3. Select the desired magnification. 
4. Click OK. 

 Exercise 6  

Magnify the worksheet to 150%, and then zoom out of the worksheet to 50% using the 
Zoom box on the standard toolbar. (“Advisor” worksheet) 

1. Look for the Zoom box on the standard toolbar  . 
2. Click the down arrow side the box and select 150%. 
3. Observe the changes in the worksheet. 
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4. Click the Zoom box, and type 50. 
5. Press Enter on the keyboard. 
6. Observe the changes in the worksheet. 
 
Magnifying a range of cells 

1. Select only the range of cells you’d like to magnify. 
2. Select View -> Zoom - >Fit Selection. 
3. Click OK. 

 Exercise 7 

Magnify a specific set of cells. (“Advisor” worksheet) 
1. Select cells A1:E17 
2. Click the down arrow in the Zoom box. 
3. Click Selection. 
4. Observe the changes in the worksheet. 
5. Change the Zoom back to 100% 

 
Freezing and Unfreezing Panes 

 
Freeze Panes 
1. To freeze both row and column headings, click once 

on the cell directly below the column heading and to 
the right of the row headings you want to freeze. 

2. From the Window menu select Freeze Panes. 
 

Unfreeze Panes 
1. Select the Window menu. 
2. Select Unfreeze Panes. 

 

 Exercise 8 

Freeze the first row of the worksheet so that it’s always showing as the first row when 
we scroll down. (“Advisor” worksheet) 

1. Click in cell A2. 
2. Select Freeze Panes from the Window menu. 
3. Scroll down past the first screen and notice that row 1 remains the top row. 
4. Select Unfreeze Panes from the Window menu. 

 
 
Finding Records 

1. Select Find from the Edit menu. 
2. In the Find What text box, type the text you want to locate in the worksheet. 
3. Click the Find Next button. Excel will highlight the text it finds with each click of 

the Find Next button. 
4. You may choose to search by rows or columns. 
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Exercise 9 

In the Advisor worksheet, find each record with “John” in the student column. 
1. Click anywhere inside the data. 
2. Select Find from the Edit menu. 
3. In the Find What text box, type John. 
4. Click the Find Next button. Excel will highlight the text it finds with each click of 

the Find Next button. 
5. Notice that student names such as “Johnson” are also targeted. 
6. Click Close. 
 

TIP! Navigate between worksheets by right clicking the worksheet navigation 
buttons  to the left of the worksheet tabs. 

 
Sorting Records  

1. Click once inside the column that you want sorted. (* Do NOT select the whole 
column.*) 

2. From the standard toolbar select  to sort in ascending order. 
3. Select to sort in descending order. 
 

Exercise 8 

In the Source Data worksheet, sort by the Order Amount column. 
1. Click inside the Order Amount column. 
2. Click the Descending Order button  from the Formatting toolbar. 
3. Notice the spreadsheet is now arranged such the largest order amount is at the 

top and the smallest order amount is at the bottom. 

4. Click the Ascending Order button . 
5. Notice the change in the order amount column. 
 

Multi-level Sorting 
You can sort by more than one field at once. 

1. From the Data menu select Sort. 
2. In the Sort by box, use the down arrow to select the first field you want sorted. 

Specify whether you want Ascending or Descending order. 
3. In the Then By boxes select up to two more field to sort. 
4. Make sure to specify whether your columns have header rows. 

 
Exercise 9 
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In the Source Data worksheet, sort first by Salesperson, then by Order Date. 
1. Select Sort from the Data menu. 
2. In the Sort by box click the down arrow and select Salesperson. Choose to sort 

by Descending order. 
3. In the Then by box click the down arrow and select Order Date. Choose to sort 

by Ascending order. 
4. Click Header Row. 
5. Click OK. 
 

Subtotaling a list 
Subtotal sections of your data. 

1. Sort list by desired field. 
2. Select the Data menu then click Subtotals. 
3. In the At each change in use the down pointing triangle to select the field to be 

subtotaled. 
4. In the Use function: box, select the function you prefer. 
5. In the Add subtotal to: box, click the check box for each field you’d like totaled. 
6. Click Replace current subtotal and Summary below data. 

Your workbook will show subtotals in Outline form. Us the Detail level buttons or the 
Level Symbols to control how much information is displayed. To Remove subtotal go to 
the Data menu, click Subtotals then click Remove All. 

Exercise 10 

Subtotal the Order Amount for each Salesperson. 
1. With the Salesperson column sorted, select the Data 

menu then click Subtotals. 
2. In the  At each change in: box use the down 

pointing triangle to select Salesperson.  
3. In the Use function: box, select the SUM function. 
4. In the Add subtotal to: box, click only the Order 

Amount box. 
5. Click OK. 
6. Review subtotals, then remove them (Data-

>Subtotals->Remove All).  
 

Filtering Data 
1. Click on any cell in the field to be filtered. 
2. From the Data menu, point to Filter and select AutoFilter. 
3. Notice dropdown menus to the right of each column heading. 
4. Click the down arrow for the field you want displayed and select the desired 

category. 
To turn off the AutoFilter feature, go to the Data menu, point to Filter and select 
AutoFilter. 

 Exercise 11 
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Using the Source Data worksheet, use AutoFilter to display all the records where 
Peacock is the salesperson. Then filter out all the records from the USA. 

1. From the Data menu, point to Filter and select AutoFilter. 
2. Notice the dropdown menu to the right of each column heading. 
3. Click the dropdown menu to the right of the Salesperson column. 
4. Select Peacock. 
5. Notice that only the records with Peacock as the Salesperson are displayed. 
6. From the Data menu, point to Filter and select Show All. 
7. Click the dropdown menu to the right of the Country column. 
8. Select USA. 
9. Notice that only the records from the USA are displayed. 
10. From the Data menu, point to Filter and select Show All. 
11. From the Data menu, point to Filter and select AutoFilter. 
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Formula Review 

Exercise 12 

Complete the timesheet by 
putting appropriate formulas 
in the following fields: Week 
2 Total, Hours Worked, 
Gross Pay. 
1. Click in F27 (Week 2 

Total) 
2. Click the AutoSum 

button  
3. Press Enter on the 

keyboard. 
4. Click in C31 (Hour 

Worked) 
5. Type = 
6. Click F17 (Week 1 Total) 
7. Type + 
8. Click F27 (Week 2 Total) 
9. Press Enter. Notice the 

sum is calculated in C31 
(Hours Worked) 

10. Click C32 (Gross Pay). 
11. Type = C31 * B31 (This 

multiplies the Flat Rate 
and the Hours worked) 

12. Press Enter on the 
keyboard. 

13. Format C32 (Gross Pay) 
to currency style by 
clicking the  on the 
toolbar. 

14. Enter fake hours into the 
timesheet to make sure it 
calculates properly. 

 
 
 
 
3-D Formulas 
3-D formulas include cell references from other worksheets in the same or different 
workbooks. In 3-D formulas the worksheet names are separated from the cell address 
by an exclamation point (!).  
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Exercise 15 

In worksheets 2003, 2004 and 2005 Buchanan’s sales totals are in the same cell 
location D12. In this scenario, we can use a 3-D function to Sum D12 across 3 different 
worksheets.  

1. Click the 3-Year Totals worksheet tab 
2. Click B2, the cell which will hold the 3 year 

total sales for Buchanan. 
3. Click the AutoSUM Button. The formula bar 

should read : =SUM() 
4. Click the 2003 worksheet tab.  
5. Click cell D12, which holds the total sales by 

Buchanan for the year 2003. 
6. Hold the Shift key down and click the 2004 worksheet tab. Notice how both 

2003 and 2003 tabs are selected. 
7. Continue to hold down the Shift key and click the 2005 worksheet tab.  
8. Notice the formula bar should read: =SUM('2003:2005'!D12). 
9. Press Enter. 

Exercise 16 

In the 3-Year Totals worksheet, use a 3-D formula to calculate the total Sale Order 
Amount each salesperson sold for 2003 – 
2005. 

1. Click the 3-Year Totals worksheet 
tab 

2. Click B3, the cell which will hold 
the 3 year total sales for Callahan. 

3. Type = 
4. Click the 2003 worksheet tab. 
5. Click cell D30, which holds the 

total sales by Callahan for the year 
2003. 

6. Type + 
7. Click the 2004 worksheet tab. 
8. Click cell D68, which holds the 

total sales by Callahan for the year 
2004. 

9. Type + 
10. Click the 2005 worksheet tab. 
11. Click cell D40, the cell which holds the total sales by Callahan for the year 

2005 
12. Press Enter 
13. Practice this type of formula by repeating these steps for Davolio. 
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Conditional Formulas 

If functions provide a value based on a condition you specify. It is structured as 
follows: 
=IF(conditional test, value if true, value if false) 

 Exercise 17 

Import a table of student grades from the following webpage 
http://www.ncsu.edu/it/education/training/excel/grades.html  

In a fictional Pass/Fail course, students must make a final grade of 60 or greater to pass 
the course, otherwise they fail. Use an If function to enter “Pass” or “Fail” in column F. 

4. In f2 enter: =If(e2>=60, “Pass”, “Fail”) 
5. Copy this formula down the whole column. Right-click F2, select copy. Select the 

rest of the cells in column F. Right-click selected cells, click Paste. 
 

 Exercise 18  

In the previous example we specified “60” in our formula as the score needed to pass 
the course. If we later decided to change the passing score to something else, we’d 
have to make that change in each formula. We can avoid this problem by referring to 
another cell instead of using an actual number. This way, if we decide to change the 
score required to pass, we could make the change in one place and all the records 
would be affected.  
 
Designate cell H2 to contain the Passing Grade, Change the Conditional formula used 
in the previous exercise such that it reference H2 instead of 60. Copy the formula and 
paste it to the remaining rows. 
 

1. In cell H1 type, Passing Grade.  
2. In cell H2 type, 60. 
3. Modify the formula in cell F2 (the Grades column) to =If(e2>=H2, “Pass”, 

“Fail”) 
4. Copy this formula down the whole column. Right-click F2, select copy. Select 

the rest of the cells in column F. Right-click selected cells, click Paste. The 
Grades should have stayed the same since we didn’t change the score 
required to pass. However, notice how everyone is now passing the course. 

5. Click cell F3 and look at the formula in the formula bar. Notice how it no 
longer references H2 but H3. 

6. Click cell F3 and look at the formula in the formula bar. Notice how it no 
longer references H2 but H4. 

The feature that adjusts a formula as it is copied across a row or down a column is no 
longer working in our favor. To force the formula to reference H2 in every case, we need 
to create an absolute reference to H2 in formula, and then copy it to the remaining rows. 
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Absolute and Relative References 

When formulas with relative cell references are copied, its cell references adjust to its 
new location. Absolute cell references don’t change when its formula is copied. A dollar 
sign ($) typed before the column letter and before the row number creates an absolute 
cell reference. Pressing the [F4] key repeatedly toggles you through each of the four 
types of cell references. 
 
Cell 
Entry 

Type of 
Referencing 

Result 

C1 Relative Both the row and column will change when copied to 
another location. 

$C1 Mixed The column will not change when copied to another 
location, but the row will. 

C$1 Mixed The row will not change when copied to another 
location, but the column will. 

$C$1 Absolute The column and the row will not change when copied to 
another location. 

 

 Exercise 19 

1. Double click cell F2. 
2. Move the insertion point to the reference that needs to be made absolute (in-

between the H and the 2). 
3. Press the F4 key until H2 looks like $H$2 (only takes one press, but go ahead 

and toggle through the other options until you get back to the one we want). 
4. Press the Enter key. 
5. Copy this formula down the whole column. Right-click F2, select copy. Select 

the rest of the cells in column F. Right-click selected cells, click Paste. 

Nested IF functions 

When more than one condition must be tested, nested If functions may be used (up to 7 
conditions deep). 
=IF(conditional test, value if true, If(conditional test 2, value if true, value if false)). 

 
 Exercise 20  

In an alternative Pass/Fail grading system, student can earn a “Pass”, “D” or “Fail”. 
Write a nested if statement that enters “Pass” for grades above 69, enters “Fail” for 
grades less than 60 and a “D” for anything in-between. 
 

4. In H2 type, 69 
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5. In I1 type Failing if below. 
6. In I2, type the score for failing, 60   
7. In cell F2 enter, =If(e2>$H$2, “Pass”, If(e2<$I$2, “Fail”, “D”)) 
8. Copy this formula down the whole column. Right-click F2, select copy. Select the 

rest of the cells in column F. Right-click selected cells, click Paste. 
 
Password Protecting Your Workbook 

1. From the File menu, select Save As. 
2. In the Save As dialog box, click Tools, and then select General Options. 
3. You have two options for password protecting your workbook. 

a. Require a password to open the workbook. 
b. Require a password to modify the workbook. 

4. Type in your password and click OK. Retype your password and click OK. 

Exercise 21 

1. From the File menu, select Save As. 
2. From the Tools menu, in the Save As window, select General. 
3. In the password to modify box type: modify 
4. Click OK. 
5. Retype: modify. 
6. Click OK. 
7. Save your document with its original name, classinfo. Close the document. 
8. Open classinfo. 
9. Type modify in the password box and press Enter on the keyboard. 
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Thank you for your interest in Student Education. We hope that this class has been 
helpful. If you have additional questions or comments about this class or any others, 
please contact us at classreg@ncsu.edu or leave us feedback at out webpage, 
http://www.ncsu.edu/it/education/students.  


